X-Plane Mobile Operating System Requirements

New Requirements

As of X-Plane Mobile version 11.1.0, we have changed our operating system requirements. If your device does not support meet these new requirements, you will still be able to access X-Plane Mobile version 11.0.3. Your subscription status/in-app purchases will not be altered by this either.

Android devices must have Android 6.0 or newer installed to receive X-Plane Mobile 11.1.0 and beyond.

iOS devices must have iOS 13 or newer installed to receive X-Plane Mobile 11.1.0 and beyond.

Why is this change necessary?

X-Plane Mobile is loaded with detail: our full 3D cockpits, our realistic sounds, our global scenery and more! These incredible details require memory (RAM). This isn’t the kind of memory that you can increase with an SD card. It’s the type of memory that cannot be changed by the user. Most of the mobile devices commonly used run X-Plane Mobile just fine, however there are a smaller percentage of older devices that have a small amount of RAM available. On these low-RAM devices, the OS itself uses half of the memory that the device has available to it, leaving other apps with what’s left over. If we are to continue adding more and more features to the product like we plan, we need to make sure there’s enough RAM available for us. Moving the OS requirements forward allows us continue adding new features for most users without affecting low-RAM devices.

We realize that mobile devices can be expensive and certainly do not expect everyone to have the latest and greatest devices, and we don’t take these decisions lightly when they do have to be made.

Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.

Still need help? Contact Us Contact Us