X-Plane 11.50 Add-On Compatibility

Some 3rd-party X-Plane add-ons require updates for use with X-Plane 11.50. Here is a list of add-ons that are currently known to be problematic. If you are having issues with any plugin, regardless of its listing below, please make sure you have the latest update. Next, contact the developer for any further assistance. Our support team cannot be of service for this, unfortunately.

  • Reshade (entirely disabled)
  • XPUIPC
  • FSEconomy
  • Goodway Flight Planner
  • Scenery Animation Manager (SAM)
Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.

Still need help? Contact Us Contact Us